Back to overview
Downtime

Maintenance

Feb 15 at 02:37pm EST
Affected services
debate.land

Updated
Feb 29 at 01:00am EST

Some circuits are still being readded to the site. We have restored some service to certain circuits and are working hard to continue rebuilding our circuit base.

Created
Feb 15 at 02:37pm EST

See the maintenance page; we apologize for any inconvenience.